Skip to content
EntityQ76497· pop 24· linked from 445 articles

Uniform Resource Name

Sign in to save

Also known as Uniform Resource Names, urn

URNスキームを採る統一資源識別子、URI

Wikidata facts

Show 4 more facts
NCI Thesaurus ID
C71581
Commons category
Uniform Resource Name
Stack Exchange tag
stackoverflow.com/tags/urn

via Wikidata · CC0

Article · 日本語

Uniform Resource Name(URN, 統一資源名)は、urn スキームを使った Uniform Resource Identifier (URI) であり、それによって識別されるリソースにアクセス可能かどうかは含意しない。URN(名前)とURL(ロケータ)はどちらもURIであり、あるURIは同時に名前でありロケータでもありうる。 URN の機能要求仕様は RFC 1737 で記述されている。URNは、URN、URC、URL (Uniform Resource Locator)から構成されるインターネット情報アーキテクチャの一部である。それぞれには、以下のような役割がある。 * URN は識別に使われる。 * URC はメタ情報を付与するためにある。 * URL はリソースの位置を示し、探すためにある。 RFC 2141 ("URN Syntax") によれば、 Uniform Resource Names (URNs) は、永続的で位置に依存しないリソース識別子であり、URNと属性を共有する他の名前空間をURNの名前空間に簡単にマッピングできるよう設計されている。したがって、URNの文法は、既存のプロトコルで送信でき、多くのキーボードで入力できるといった形式で文字データをエンコードする手段を提供する。 RFC 3986 ("Uniform Resource Identifier Generic Syntax") には以下のように述べられている。 "Uniform Resource Name" (URN) という用語はこれまで、"urn"スキームでのURI(RFC 2141)と名前の属性を持つ他の様々なURIも指してきた。前者は、リソースが存在しなくなったり、利用できなくなった時でもグローバルに一意で永続的に存在することを要求される。

Abstract from DBpedia / Wikipedia · CC BY-SA