Skip to content
EntityQ2385453· pop 12· linked from 194 articles

Open Network Computing Remote Procedure Call

Sign in to save

Also known as ONC RPC, Sun Remote Procedure Call

computer network protocol

Wikidata facts

Show 2 more facts
port
111
OSI Model layer location
session layer
Sources (1)

via Wikidata · CC0

Article · Português

O Open Network Computing Remote Procedure Call (frequentemente abreviado para ONC RPC; ou ainda, Sun ONC e Sun RPC) é um sistema de chamada de procedimento remoto, desenvolvido originalmente pela Sun Microsystems como parte do projeto Network File System. O sistema é baseado nas convenções de chamada usadas em Unix e em C. Ele serializa os dados usando a linguagem de descrição de interface XDR, que também é usado para codificar e decodificar dados em arquivos que são acessados em mais de uma plataforma. A transmissão do XDR é feita através de UDP ou TCP. O acesso aos serviços de uma máquina é feito através de um mapeador de portas que aguarda requisições em portas conhecidas. Existem implementações do ONC RPC na maioria dos sistemas Unix-like. Já a Microsoft fornece uma implementação para Windows como parte do ; mas também diversas implementações externas para Windows doutros fornecedores. O ONC RPC é descrito no RFC 1831, e os mecanismos de autenticação usados pelo sistema são descritos em RFC 2695, RFC 2203 e RFC 2623.

Abstract from DBpedia / Wikipedia · CC BY-SA