Skip to content
Extensible Messaging and Presence Protocol

File:XMPP_logo.svg · Wikimedia Commons · See Wikimedia Commons

EntityQ188951· pop 47· linked from 768 articles

Extensible Messaging and Presence Protocol

Sign in to save

Also known as Jabber

Extensible Messaging and Presence Protocol (abbreviation XMPP, originally named Jabber) is an open communication protocol designed for instant messaging (IM), presence information, and contact list maintenance. Based on XML (Extensible Markup Language), it enables the near-real-time exchange of structured data between two or more network entities. Designed to be extensible, the protocol offers a multitude of applications beyond traditional IM in the broader realm of message-oriented middleware, including signalling for VoIP, video, file transfer, gaming and other uses.

Key facts

Network protocol.logo
XMPP logo.svg
Network protocol.purpose
Instant messaging
Network protocol.rfcs
RFC 6120 (Core), RFC 6121 (IM & Presence), RFC 7622 (Address Format), RFC 3922 (CPIM), RFC 3923 (Encryption)
Network protocol.logo size
175px
Network protocol.osilayer
Application layer
Network protocol.ports
TCP 5222, 5269, 8010

via Wikipedia infobox

Official website

XMPP - The universal messaging standard | The universal messaging standard

XMPP is the Extensible Messaging and Presence Protocol, a set of open technologies for instant messaging, presence, multi-party chat, voice and video calls, collaboration, lightweight middleware, content syndication, and generalized routing of XML data.

xmpp.org →

Link to the official site · 3,226 chars · not written by Vinony

Wikidata facts

Subclass of
online chat
Official website
xmpp.org
Image
Jabber xml.png
Show 9 more facts
Commons category
Extensible Messaging and Presence Protocol
port
5269
topic's main category
Category:XMPP
Stack Exchange tag
stackoverflow.com/tags/xmpp
OSI Model layer location
application layer
used by
Jitsi
inception
1999-00-00
different from
XAMPP
Sources (4)

via Wikidata · CC0

Gallery (20)