
Key facts
- Software.name
- OpenSSH or OpenBSD Secure Shell
- Software.logo
- OpenSSH logo.png
- Software.logo size
- 190px
- Software.logo caption
- "Keeping your communiqués secret"
- Software.developer
- The OpenBSD Project
- Software.programming_language
- C
- Software.operating system
- Cross-platform
- Software.genre
- Remote access
- Software.license
- BSD, ISC, public domain
- Software.standard
- RFC 4250, RFC 4251, RFC 4252, RFC 4253, RFC 4254, RFC 4255, RFC 4256, RFC 4335, RFC 4344, RFC 4345, RFC 4419, RFC 4462, RFC 5656, RFC 6594, RFC 6668, RFC 7479
via Wikipedia infobox
Official website
Link to the official site · 1,572 chars · not written by Vinony
Wikidata facts
- Official website
- www.openbsd.org/openssh
- Image
- OpenSSH CLI.png
- Has use
- Secure Shell
Show 11 more facts
- Commons category
- OpenSSH
- operating system
- Windows Server 2025
- copyright license
- ISC license
- software version identifier
- 10.3
- different from
- OpenSSL
- mailing list archive URL
- lists.mindrot.org/pipermail/openssh-unix-announce
- programmed in
- C
- inception
- 1999-12-01
- source code repository URL
- anongit.mindrot.org/openssh.git
- implementation of
- secure copy protocol
- build system
- GNU build system
Sources (11)
via Wikidata · CC0
Article · Nederlands
OpenSSH is een opensourceimplementatie van het SSH (Secure Shell)protocol, uitgebracht onder de BSD-licentie. In tegenstelling tot telnet, rlogin en FTP worden wachtwoord en data met encryptie over het netwerk gestuurd. OpenSSH versleutelt al het verkeer (inclusief wachtwoorden) om afluisteren, het overnemen van een verbinding en andere aanvallen tegen te gaan. Daarnaast bevat OpenSSH veilige "tunneling" mogelijkheden en verschillende authenticatiemethodes, en het ondersteunt alle SSH-protocolversies. OpenSSH vervangt rlogin en telnet door het SSH-programma, door SCP en FTP door SFTP. Ook is sshd inbegrepen (het server-gedeelte van het pakket), net als de andere programma's zoals ssh-add, ssh-agent, ssh-keysign, ssh-keyscan, ssh-keygen en sftp-server. OpenSSH wordt ontwikkeld door het OpenBSD-project. De software wordt ontwikkeld in landen die uitvoer van cryptografie toelaten en is vrij te (her)gebruiken onder de BSD-licentie. Ontwikkeling brengt echter kosten met zich mee, deze kosten worden voornamelijk met geld uit donaties gedekt. OpenSSH wordt ontwikkeld door twee teams. Eén team ontwikkelt uitsluitend voor OpenBSD met als doel zo schoon, simpel en veilig mogelijke code te schrijven. Ze geloven dat eenvoud zonder extra code om portabiliteit te verhogen, betere kwaliteitscontrole mogelijk en nakijken makkelijker maakt. Het andere team maakt deze versie portable (door de portabiliteitscode toe te voegen) zodat het op veel besturingssystemen kan draaien -- de zogenaamde p-versies, bv. "OpenSSH 4.3p2"). OpenSSH is beschikbaar voor vrijwel alle platformen en wordt door veel besturingssystemen en routers meegeleverd. Vrijwel alle Unix- en Linux-versies gebruiken inmiddels OpenSSH, fabrikanten als Cisco leveren het mee in routers en switches.Door de jaren heen heeft OpenSSH zich bewezen als veilig en betrouwbaar.
Abstract from DBpedia / Wikipedia · CC BY-SA